How to connect a Cisco IOS router equipped with ISDN to BT ClickFree
The following is a configuration used on a Cisco 1603 (IOS 11.3.8T1) for connecting to 
BT ClickFree (http://www.btclickplus.com)  service. 

This configuration uses IP NAT to connect a private address (RFC 1597) LAN to the Internet.

I think the service authenticates with any PPP chap hostname, but I write "BTClickFree" just
for the descriptive value.

version 11.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname bogus-gw
!
enable password password
!
username BTMDIP password 7 015124301B280A062247681B1C0055
ip subnet-zero
no ip source-route
ip nat inside source list 10 interface Dialer0 overload
ip name-server 193.212.1.10
ip name-server 193.212.1.11
isdn switch-type basic-net3
isdn tei-negotiation first-call
!
clock timezone MET 1
clock summer-time MET-DST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
interface Ethernet0
ip address 192.168.5.49 255.255.255.0
no ip directed-broadcast
ip nat inside
!
interface BRI0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 no keepalive
 dialer pool-member 1
 isdn switch-type basic-net3
 no fair-queue
 ppp chap hostname BTClickFree
 ppp multilink
!
interface Dialer0
 ip address negotiated
 ip access-group 120 in
 no ip directed-broadcast
 ip nat outside
 encapsulation ppp
 load-interval 30
 no keepalive
 dialer remote-name BTClickFree
 dialer string 08457576333
 dialer pool 1
 dialer-group 1
 no fair-queue
 no cdp enable
 ppp chap hostname BTClickFree
 ppp multilink
!
ip classless
ip default-network 193.212.1.0
ip route 0.0.0.0 0.0.0.0 Dialer0
!
logging trap debugging
access-list 10 permit 192.168.5.0 0.0.0.255
access-list 120 permit ip any any
dialer-list 1 protocol ip list 120
!
line con 0
 exec-timeout 0 0
line vty 0 4
 exec-timeout 0 0
 login
!
end